Mikrotik. Уведомление о подключении по L2TP

Чтобы знать о подключениях из вне к вашей сети, микротик может высылать  вам на почту уведомления.

В моем случае я настраивая для L2TP но можно и для других типов VPN (PPTP,  IPSec) проделать тоже самое.

Эта настройка подразумевает, что вы уже настроили VPN соединение  и создали пользователя для подключения.

заходим на микротик -> PPP-> Profiles -> выбираем подключение, в моем случае это L2TP, открываем его и переходи на закладку скрипты и в On UP вставляем код:

:local email "Указываем почту" ##### Тело скрипта /tool e-mail send to=$email server=ipАдресПочтовогоСервера subject="User $user connected VPN" body="User $user connected over $[/ppp active get [/ppp active find where name=$user caller-id=$"caller-id" address=$"remote-address"] service] at $[/system clock get time].\r\nIP-adress - $"caller-id""

Указываем почту на которую будет приходить сообщения и ip адрес почтового сервера

в окно ON Down вставляем код:

:local email "Указываем почту" ##### Тело скрипта /tool e-mail send to=$email server=ipАдресПочтовогоСервера subject="User $user turn off VPN" body="User $user turn off at $[/system clock get time]."

нажимаем Apply.

далее открываем Tools-> Email

В поле Server : я указал имя почтового сервера, можно и ip

Port : 25

Start TLS: yes

From: почту с которой будут уходить сообщения

поля User и password  я оставил не заполненные.

нажимаем apply и ok.

 

Теперь при подключении и отключении через VPN вы будете видеть в почте такого вида сообщения:

При подключении

User ИмяПодключившегося connected over pptp at 22:21:14.
IP-adress - IPАдресПодключившегося

При отключении

User ИмяПодключившегося turn off at 22:21:45.

 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Капча загружается...

© 2018 FIL